Nette Documentation Preview

syntax
Nástroje
********

.[perex]
V balíčku `nette/utils` najdete sadu užitečných tříd pro každodenní použití:

| [Callback] | Nette\Utils\Callback
| [Datum a čas |datetime] | Nette\Utils\DateTime
| [Finder] | Nette\Utils\Finder
| [HTML elementy |html-elements] | Nette\Utils\Html
| [JSON |json] | Nette\Utils\Json
| [Náhodné řetězce |random] | Nette\Utils\Random
| [Obrázky |images] | Nette\Utils\Image
| [PHP reflexe |reflection] | Nette\Utils\Reflection
| [PHP typy |type] | Nette\Utils\Type
| [Pole |arrays] | Nette\Utils\Arrays
| [Pomocné funkce |helpers] | Nette\Utils\Helpers
| [Porovnávání floatů |floats] | Nette\Utils\Floats
| [Řetězce |strings] | Nette\Utils\Strings
| [Souborový systém |filesystem] | Nette\Utils\FileSystem
| [Stránkování |paginator] | Nette\Utils\Paginator
| [SmartObject] & [StaticClass] | Nette\SmartObject & Nette\StaticClass
| [Validátor |validators] | Nette\Utils\Validators


Instalace
---------

Knihovnu stáhnete a nainstalujete pomocí nástroje [Composer|best-practices:composer]:

```shell
composer require nette/utils
```

| verze     | kompatibilní s PHP
|-----------|-------------------
| Nette Utils 4.0 | PHP 8.0 – 8.3
| Nette Utils 3.2 | PHP 7.2 – 8.3
| Nette Utils 3.0 – 3.1 | PHP 7.1 – 8.0
| Nette Utils 2.5 | PHP 5.6 – 8.0

Platí pro poslední patch verze.

Nástroje

V balíčku nette/utils najdete sadu užitečných tříd pro každodenní použití:

Callback Nette\Utils\Callback
Datum a čas Nette\Utils\DateTime
Finder Nette\Utils\Finder
HTML elementy Nette\Utils\Html
JSON Nette\Utils\Json
Náhodné řetězce Nette\Utils\Random
Obrázky Nette\Utils\Image
PHP reflexe Nette\Utils\Reflection
PHP typy Nette\Utils\Type
Pole Nette\Utils\Arrays
Pomocné funkce Nette\Utils\Helpers
Porovnávání floatů Nette\Utils\Floats
Řetězce Nette\Utils\Strings
Souborový systém Nette\Utils\FileSystem
Stránkování Nette\Utils\Paginator
SmartObject & StaticClass Nette\SmartObject & Nette\StaticClass
Validátor Nette\Utils\Validators

Instalace

Knihovnu stáhnete a nainstalujete pomocí nástroje Composer:

composer require nette/utils
verze kompatibilní s PHP
Nette Utils 4.0 PHP 8.0 – 8.3
Nette Utils 3.2 PHP 7.2 – 8.3
Nette Utils 3.0 – 3.1 PHP 7.1 – 8.0
Nette Utils 2.5 PHP 5.6 – 8.0

Platí pro poslední patch verze.