Nette Documentation Preview

syntax
Přechod na novější verze
************************

- [z Nette 3.0 na 3.1 |to-3-1]
- [z Nette 2.4 na 3.0 |to-3-0]
- [z Nette 2.3 na 2.4 |to-2-4]
- [z Nette 2.2 na 2.3 |to-2-3]
- [z Nette 2.1 na 2.2 |to-2-2]
- [z Nette 2.0 na 2.1 |to-2-1]


Aktualizujte vždy postupně, takže nikoliv z Nette 2.4 na 3.1, ale nejprve na 3.0 a poté na 3.1.

Před testováním nebo nasazováním doporučujeme nejprve vypnout hlášení chyb `E_USER_DEPRECATED` a povolit jej, až když vše bude fungovat:

```php
$configurator->enableTracy();
error_reporting(~E_USER_DEPRECATED); // všimněte si ~ před E_USER_DEPRECATED
```


Upgrade na nejnovější verze
---------------------------

Verze balíčků v souboru `composer.json` zvednete na nejnovější nejsnáze pomocí skriptu [composer-frontline.php|https://gist.github.com/dg/734bebf55cf28ad6a5de1156d3099bff]. Spusťte jej v adresáři, kde je i soubor `composer.json`, pomocí:

```shell
php composer-frontline.php
```

Přechod na novější verze

Aktualizujte vždy postupně, takže nikoliv z Nette 2.4 na 3.1, ale nejprve na 3.0 a poté na 3.1.

Před testováním nebo nasazováním doporučujeme nejprve vypnout hlášení chyb E_USER_DEPRECATED a povolit jej, až když vše bude fungovat:

$configurator->enableTracy();
error_reporting(~E_USER_DEPRECATED); // všimněte si ~ před E_USER_DEPRECATED

Upgrade na nejnovější verze

Verze balíčků v souboru composer.json zvednete na nejnovější nejsnáze pomocí skriptu composer-frontline.php. Spusťte jej v adresáři, kde je i soubor composer.json, pomocí:

php composer-frontline.php